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1. WSTĘP 

W chwili obecnej grafika 3D jest szeroko stosowana w życiu codziennym, choć nie zawsze zdajemy sobie z tego 

sprawę. Rozwój oprogramowania i technologii znacznie przyspiesza pracę co również przekłada się na 

popularność tej dziedziny.  

Wizualizacje architektoniczne są również produktem bardzo popularnym i znajdują wiele różnorakich 

zastosowań w dziedzinach takich jak konsultacje społeczne, uzgodnienia z inwestorami, koncepcje i konkursy 

architektoniczne oraz marketing. Modele 3D obiektów architektonicznych są również wykorzystywane do 

tworzenia makiet inwestycji w technice druku 3D. W przypadku konsultacji społecznych badania wykazały, że 

zastosowanie wizualizacji pozytywnie wpływa na odbiór projektu i jest przychylnie odbierane przez 

społeczeństwo.  

Wizualizacja obiektu istniejącego nie jest bardzo częstym przypadkiem. Można jednak dla takiego projektu 

znaleźć wiele zastosowań. Przede wszystkim można w bezinwazyjny sposób sprawdzić efekty ewentualnego 

remontu lub przebudowy. Zaproponowaną wizję można w łatwy sposób modyfikować, aż do osiągnięcia 

oczekiwanego rezultatu. 

Celem pracy jest stworzenie wizualizacji 3D kampusu Krakowskiej Akademii, która zaprezentuje teren uczelni. 

Taki sposób przedstawienia, który oczywiście stanowi uproszczenie otaczającej nas rzeczywistości pozwala 

oglądającym na skupienie się tylko na istocie rozwiązań architektonicznych. Wizualizacje 3D w prostej linii 

wywodzą się z tradycji wykonywania makiet obiektów architektonicznych.  

Wybierając temat pracy kierowałem się przede wszystkim swoim zamiłowaniem do grafiki trójwymiarowej oraz 

architektury. Jednocześnie chciałem zwrócić uwagę na korzyści płynące z zastosowania cyfrowej wizualizacji 

3D przy projektowaniu architektonicznym. Jako obiekt wybrałem kampus Krakowskiej Akademii przede 

wszystkim ze względu na jego atrakcyjność. Bardzo ważne było również dla mnie aby stworzyć wizualizacje dla 

obiektu już istniejącego. Kolejnym znaczącym czynnikiem mojej decyzji był fakt, że moja praca potencjalnie 

może znaleźć jakieś zastosowanie z korzyścią dla Krakowskiej Akademii. Stworzona cyfrowa wersja kampusu 

mogłaby z powodzeniem zostać wykorzystana np. do stworzenia aplikacji z cyfrową mapą kampusu 

Krakowskiej Akademii lub wykonania makiety w technice druku 3D. 

Do stworzenia projektu 3D zostało wykorzystane niezwykle wszechstronne oprogramowanie Cinema 4D. 

Zastosowanie znalazły również programy do grafiki rastrowej (Adobe Photoshop) oraz efektów specjalnych w 

animacji (Adobe After Effects).  Pracę poprzedziło zgromadzenie materiałów źródłowych i referencyjnych w 

postaci zdjęć, map i szkiców. Wykonanie modelu 3D kampusu i otoczenia Krakowskiej Akademii, 

teksturowanie, oświetlenie i rendering w programie Cinema 4D przy użyciu silnika renderującego VrayForC4D 

stanowiło główną część pracy. Uzyskane rezultaty zostały poddane obróbce w Adobe Photoshop CS6 i Adobe 

After Effects CS6. 
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2. GRAFIKA 3D – INFORMACJE PODSTAWOWE, OPROGRAMOWANIE, METODY 

2.1.  Informacje podstawowe 

Grafika 3D to dziedzina grafiki komputerowej zajmująca się odwzorowaniem obiektów trójwymiarowych. W 

obecnych czasach jest bardzo powszechna i stosowana w wielu dziedzinach przemysłu. Przy użyciu 

oprogramowania do generowania grafiki 3D wykonuje się wysokiej jakości wizualizacje inwestycji, wnętrz, 

projektów architektonicznych, filmy, reklamy i animacje, gry, prezentacje produktów, analizy i symulacje a 

nawet diagnostykę medyczną. 

Współczesny sprzęt i oprogramowanie umożliwiają bardzo realistyczne odwzorowanie rzeczywistości 

otwierając przy tym niezliczone możliwości niedostępne w fotografii. Z tego powodu obecnie praktycznie nie 

wykonuje się zdjęć produktów do reklam, gdyż grafika 3D jest bardziej efektowna i efektywna. Nie zmienia to 

faktu, iż bardzo wiele elementów związanych z tworzeniem finalnego obrazu 3D oparte jest na zasadach 

fotografii. Większość programów korzysta z obiektu wirtualnej kamery, której parametry takie jak ogniskowa i 

czas przesłony wpływają na generowany obraz. Związki z fotografią i kinematografią są bardzo silne co 

umożliwia wykorzystywanie technik kompozycji i wiedzy z tego zakresu w przestrzeni wirtualnej co z kolei 

wpływa pozytywnie na realność tworzonych obrazów. I choć nie jest to jedyne zastosowanie to właśnie idealne 

odwzorowanie rzeczywistości jest celem większości producentów oprogramowania i grafików. 

W większości przypadków przestrzeń trójwymiarowa przedstawiona jest w układzie kartezjańskim. Każdy 

obiekt w scenie ma swoje współrzędne i atrybuty. Obiekty 3D tworzone są z wieloboków (poligonów) o co 

najmniej trzech wierzchołkach (punktach, vertexach), które połączone są liniami. Zbiór tych linii tworzy siatkę 

obiektu. W praktyce zazwyczaj stosuje się wieloboki o trzech lub czterech vertexach ponieważ algorytmy 

wykorzystujące wieloboki o innej ilości wierzchołków (tzw. N-gons) są dużo mniej efektywne. Okno, przez 

które spoglądamy do naszego świata 3D nazywane jest zazwyczaj Viewportem. Jako geometrię wyświetlania 

możemy wykorzystywać dowolne rzuty proste lub oglądać naszą przestrzeń w rzucie perspektywicznym. Efekt 

wizualny skrótu perspektywicznego jest analogiczny do efektu obserwowanego w fotografii. Za pomocą 

wirtualnej kamery, która jak każdy obiekt w scenie ma swoje współrzędne i kierunek określamy jaka część 

modelu 3D będzie widziana w końcowym obrazie. Grafika 3D jest obecnie techniką bardzo popularną i szeroko 

dostępną. Dzięki ciągle ulepszanemu oprogramowaniu jest również coraz bardziej przyjazna dla użytkowników i 

oferuje niesamowite możliwości. W najbliższym czasie należy spodziewać się rozwoju silników renderujących 

opartych na procesorach graficznych GPU, co powinno znacznie ułatwić i przyspieszyć proces renderingu. 

2.2. Oprogramowanie 

W chwili obecnej na rynku dostępna jest niezliczona ilość oprogramowania do tworzenia grafiki 3D. Są to 

zarówno wyspecjalizowane produkty do konkretnych zastosowań, proste edytory z predefiniowanymi 

ustawieniami dla początkujących jak i obszerne pakiety o ogromnych możliwościach.  

Podstawowo programy można podzielić na dwie kategorie: modelery oraz renderery. Aplikacje z pierwszej 

kategorii służą przede wszystkim do tworzenia obiektów 3D przy użyciu różnorodnych technik. Renderery służą 

do tworzenia finalnych obrazów przy użyciu gotowych modeli 3D oraz różnorakich efektów (światła, shadery, 

efekty specjalne). W dodatku wiele z programów służy do kompleksowej obsługi zarówno modelowania, 

renderowania, animacji a także symulacji.  

2.2.1. Cinema 4D 

Cinema 4D to jeden z najbardziej zaawansowanych programów, a właściwie kompleksowych pakietów do 

grafiki 3D. Jest to obecnie bardzo kompletny zestaw, obejmujący praktycznie każdy aspekt modelowania, 

teksturowania, animacji, symulacji i renderingu. Jest to oprogramowanie bardzo mało popularne na rynku 

polskim, jednak szeroko reprezentowane przede wszystkim w Stanach Zjednoczonych i Wielkiej Brytanii, a 

więc w kolebkach grafiki komputerowej. Cinema 4D swoją wysoką pozycję na rynku zawdzięcza między 

innymi bardzo dobremu wsparciu producenta, niemieckiej firmy Maxon, która bardzo aktywnie rozwija swoje 

oprogramowanie.  

Cinema 4D to narzędzie dostępne również w polskiej wersji językowej, jednak moim zdaniem zdecydowanie 

bardziej korzystne jest używanie wersji anglojęzycznej.  Jest to spowodowane faktem, że właściwie wszystkie 

materiały szkoleniowe, kursy i dokumentacja tworzone są na wersji anglojęzycznej i takie postępowanie 

znacznie ułatwia naukę programu. Dlatego też na potrzeby tej pracy będę używał wersji anglojęzycznej. 

Warto również nadmienić, że Cinema 4D, moim zdaniem, ma najlepiej napisaną i zintegrowaną pomoc dla 

użytkownika. Wystarczy kliknąć na dowolny element prawym klawiszem myszy, wybrać opcję Show Help by 
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otwarło się okno, w którym nie tylko opisana jest szczegółowo każda funkcja, ale również bardzo często można 

znaleźć praktyczne przykłady zastosowania i różnice w zależności o wartości poszczególnych parametrów.   

Firma Maxon dla użytkowników przygotowała cztery wersje oprogramowania Cinema 4D. Różnią się one 

ilością funkcji i możliwościami oraz oczywiście ceną.  

Cinema 4D Prime – podstawowa wersja programu. Zawiera narzędzia do modelowania, tworzenia materiałów, 

teksturowania, oświetlenia, animacji, moduł BP UV Edit służący do tworzenia mapowania UV. Pakiet zawiera 

również silnik renderujący Advanced Renderer (Standard), narzędzia API: C++, Python, C.O.F.F.E.E. 

Dodatkowo do oprogramowania dołączona jest biblioteka predefiniowanych materiałów, obiektów i ustawień. 

Cinema 4D Broadcast – wersja przygotowana specjalnie dla rynku reklamy i telewizji. Zawiera wszystkie 

funkcjonalności wersji Prime oraz dodatkowo: silnik renderujący Physical Renderer, zaawansowane narzędzia 

kamer, moduł Team Render (trzy komputery), moduł MoGraph i rozszerzoną bibliotekę zasobów. 

Cinema 4D Visualize – wersja do tworzenia wizualizacji. Podobnie jak Broadcast zawiera wszystkie 

funkcjonalności wersji Prime, silnik renderujący Physical, zaawansowane narzędzia kamer oraz moduł Team 

Render (trzy komputery). Oprócz tego mamy do dyspozycji moduł Sketch & Toon, zaawansowane narzędzia 

oświetlenia i bibliotekę materiałów i obiektów do tworzenia wizualizacji. 

Cinema 4D Studio – najbogatsza wersja programu. Zawiera wszystkie funkcjonalności i biblioteki dostępne w 

pozostałych wersjach oraz między innymi: symulacje i dynamikę, rzeźbienie, system do tworzenia włosów, 

zaawansowane narzędzia do animacji postaci, Motion Tracking (efekty specjalne) i dodatkowo rozbudowaną 

biblioteką zasobów. 

Powyżej zostały wymienione tylko podstawowe funkcjonalności aby podkreślić różnice pomiędzy dostępnymi 

pakietami. Istnieje również Cinema 4D Lite o niewielkich możliwościach, dołączana darmowo do programu 

Adobe After Effects. W niniejszej pracy będę korzystał z Cinema 4D R17 Studio.  

Warto również wspomnieć o licencjach programu Cinema 4D oraz VrayForC4D. Maxon udostępnia bezpłatną 

wersję studencką pełnej wersji Studio na czas trwania studiów. W celu uzyskania licencji należy przesłać skan 

legitymacji studenckiej do polskiego dystrybutora, firmy IT-Serwis. Niestety nie ma możliwości uzyskania 

bezpłatnej licencji studenckiej silnika renderującego Vray. Wersja edukacyjna kosztuje obecnie około 1600 zł 

brutto i wymaga korzystania z rozszerzonej wersji edukacyjnej Student/Teacher Cinema 4D, która kosztuje 

około 800 zł brutto. W tej sytuacji skorzystałem z możliwości wynajęcia stanowiska z oprogramowaniem 

komercyjnym w jednej z krakowskich firm. 

2.2.2. VrayforC4D 

Cinema 4D w wersji Studio posiada dwa całkiem dobre silniki renderujące: Standard oraz Physical. Obydwa są 

dosyć szybkie i dają dobre efekty dla większości zastosowań, jednak moim zdaniem są mało wydajne jeśli 

chodzi o realistyczne rendery architektoniczne.  

Na rynku dostępne są również silniki renderujące innych firm, które posiadają integrację z programem Cinema 

4D. Najpopularniejsze z nich to Arnold, Octane Render, Thea Render, Maxwell Render, Corona oraz 

VrayForC4D. Każdy z wymienionych silników ma swoje zalety i rodzaje zastosowań, w których sprawdzają się 

najlepiej. Po dokładnej analizie problemu mój wybór padł na jeden z najpopularniejszych silników 

renderujących na świecie – Vray – bułgarskiej firmy Chaos Group. Silnik ten wykorzystuje zaawansowane 

algorytmy GI (globalnej iluminacji) oraz Path Tracing, które umożliwiają uzyskiwanie realistycznych renderów 

architektury.  W przypadku Cinema 4D wydawcą integracji Vray-a jest firma Laublab pochodząca z Austrii. 

Oficjalna nazwa pluginu to VrayForC4D i wykorzystuje ona dokładnie to samo jądro co Vray na innych 

platformach. W niniejszej pracy wykorzystam VrayForC4D w wersji 1,9, która odpowiada wersji 2,55 jądra 

Vray.  

2.2.3. Adobe Photoshop CS6 

Adobe Photoshop CS6 to oprogramowanie, którego chyba nikomu nie trzeba przedstawiać. Flagowy produkt 

firmy Adobe Systems to kompletne narzędzie do tworzenia i obróbki grafiki rastrowej.  

Oprócz niezwykle funkcjonalnego interfejsu Photoshop oferuje niezliczone możliwości edycyjne. Pakiet zawiera 

mnóstwo filtrów, pędzli, narzędzi do skalowania, transformacji, korekcji kolorów. Pracę ułatwiają gradienty, 

maski i obsługa warstw. 
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W mojej pracy Adobe Photoshop CS6 będzie służył właściwie tylko do tworzenia tekstur oraz niewielkiej 

korekcji kolorów i kontrastu renderów. 

2.2.4. Adobe After Effects CS6 

Adobe After Effects CS6 kolejny element pakietu Adobe Creative Suit 6. Program ten służy do tworzenia 

efektów specjalnych oraz szeroko pojętego compositingu (proces łączenia różnych warstw filmowych w jedną 

całość). W mojej pracy wykorzystam program Adobe After Effects do montażu animacji. 

2.3.  Metody modelowania architektonicznego 

Modelowanie obiektów architektonicznych zazwyczaj wykonuje się na podstawie rzutów architektonicznych. 

Rzuty elewacji i plany pięter stanowią wystarczającą wiedzę do wymodelowania budynku. Przydatny również 

jest plan zagospodarowania terenu.  Jednak w przypadku obiektu istniejącego, do którego nie posiadamy planów 

architektonicznych możliwe jest wykonanie całkiem dobrego modelu na podstawie innych materiałów. Są to na 

przykład zdjęcia, programy typu Google Maps i Google Earth, uproszczone szkice, pomiary bezpośrednie.  

Wykonany model można przedstawić na różne sposoby. Wizualizacja architektoniczna zazwyczaj jest obrazem 

statycznym. Bardzo często model pokazywany jest na białym tle lub w uproszczonym otoczeniu, które nie 

odpowiada rzeczywistości. Pozwala to skupić się na zaletach samego projektu i znacznie upraszcza pracę dla 

osoby wykonującej rendering. Innym sposobem jest wymodelowanie również otoczenia obiektu (bardzo 

pracochłonne) lub osadzenie renderu modelu 3D na zdjęciu rzeczywistym w programie typu Adobe Photoshop.  

Każdy ze sposobów ma swoje wady oraz zalety. Na potrzeby tego projektu zdecydowałem się na 

wymodelowanie w sposób dosyć szczegółowy całego kampusu Krakowskiej Akademii oraz uproszczonego 

otoczenia i przedstawienie całej sceny w formie makiety architektonicznej. 
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3. MATERIAŁY ŹRÓDŁOWE 

Materiały źródłowe lub inaczej materiały referencyjne to bardzo istotny element projektu. Ma on olbrzymie 

znaczenie zarówno dla etapu modelowania jak i późniejszego teksturowania i oświetlenia. Jakość tych 

materiałów nie determinuje bezpośrednio jakości efektu finalnego, może mieć jednak kluczowe znaczenie dla 

takich elementów jak czas i poziom trudności wykonania wizualizacji. Dlatego niezwykle istotne jest aby przed 

rozpoczęciem pracy w programie poświęcić jak najwięcej uwagi kompletowaniu materiałów referencyjnych. 

Referencją w tym przypadku będę nazywał wszelkie materiały, które będą ułatwiać modelowanie, oświetlenie i 

teksturowanie obiektu. Mogą to być na przykład: 

 Zdjęcia, filmy – fotografie i materiał filmowy otoczenia lub podobnych obiektów to kluczowa pomoc 

przy tworzeniu projektu 

 Plany, rysunki, mapy – tego typu materiały są niezbędnym elementem do stworzenia wizualizacji 

architektonicznej 

 Wizualizacje innych obiektów – gotowe wizualizacje innych obiektów mogą stanowić inspirację, 

pomagają wyznaczyć kierunek prac i są wzorcem jakości, do której będziemy dążyć 

 Opis wymagań od zamawiającego – jeżeli wykonujemy pracę komercyjną podstawą jest ustalenie 

wymagań inwestora. Warto również wyznaczyć punkty kontrolne, które będą konsultowane z klientem. 

Pozwoli to uniknąć nieporozumień i uciążliwych poprawek po zakończeniu projektu. 

W pracy wykorzystano dwa pierwsze źródła: zdjęcia wykonane osobiście oraz program Google Earth, który 

posłużył do pomiarów dla podstaw budynków. Resztę wymiarów określono empirycznie przyjmując przybliżone 

wartości lub po prostu za pomocą ogólnie dostępnej wiedzy dotyczącej architektury.  

 

Rys. 1. Widok z góry na kampus Krakowskiej Akademii - zrzut z programu Google Earth Pro 

Źródło: opracowanie własne 
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Rys. 2. Wybrane zdjęcia Krakowskiej Akademii wykonane na potrzeby pracy 

Źródło: opracowanie własne 
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4. TWORZENIE PROJEKTU 3D 

Pracę nad projektem 3D można podzielić na kilka podstawowych etapów.  

Faza koncepcyjna – polega na określeniu podstawowych założeń projektu oraz zebraniu jak największej ilości 

materiałów źródłowych i referencyjnych. Wysokiej jakości materiały referencyjne znacząco ułatwiają i 

przyspieszają pracę. 

Modelowanie – jest to proces tworzenia i modyfikowania obiektów 3D i wypełniania nimi sceny. Istnieje wiele 

metod modelowania 3D. Na potrzeby tej pracy zostanie wykorzystane modelowanie parametryczne przy pomocy 

predefiniowanych figur geometrycznych (tzw. prymitywy), modelowanie za pomocą powierzchni podzielonych 

(Subdivision Surface) oraz rzeźbienie (Sculpting). 

Tworzenie materiałów – czyli inaczej teksturowanie. Proces tworzenia materiałów (shaderów), które 

umożliwiają zdefiniowanie dla obiektów 3D właściwości takich jak kolor, połysk, chropowatość, 

przeźroczystość, refrakcję itp.  

Oświetlenie – proces tworzenia i definiowania parametrów świateł w scenie 3D.  

Kompozycja – to terminologia zaczerpnięta z fotografii. Dotyczy ona kilku podstawowych zasad kadrowania i 

umieszczania obiektów w scenie. Odpowiednie operowanie zasadami kompozycji pozytywnie wpływa na odbiór 

zdjęcia (również takiego pochodzącego z programu do grafiki 3D). Bardzo często etap ten jest elementem fazy 

koncepcyjnej, ponieważ pozwala skoncentrować pracę na obiektach widocznych w oku kamery. W moim 

przypadku założenia projektu pozwalały na przeniesienie tego elementu do późniejszej fazy. 

Animacja – jest to proces polegający na zdefiniowaniu ruchu obiektów w przestrzeni 3D. Etap ten również 

może być realizowany we wcześniejszym stadium projektu lub równolegle z jednym z powyższych.  

Rendering – etap zawiera ustawienie i optymalizację parametrów silnika renderującego oraz sam proces 

renderingu. Polega on na analizie sceny projektu 3D i przygotowanie na podstawie jej zawartości 

dwuwymiarowego obrazu. Taka analiza może być długotrwała i poza fazą ustawienia i optymalizacji nie 

wymaga udziału człowieka. 

Postprodukcja – proces korekty wyrenderowanego obrazu z programu 3D. Nie jest to etap konieczny jednak 

wielokrotnie potrafi ułatwić i uatrakcyjnić pracę.  

Kolejność realizacji etapów jest raczej dosyć płynna i zależy w dużym stopniu od założeń projektu. Również 

zależności pomiędzy etapami np. teksturowania i oświetlenia zmuszają do częstych powrotów do etapu 

poprzedniego w celu skorygowania pewnych wartości. 

4.1.  Modelowanie 

Etap modelowania w przypadku niniejszej pracy był z pewnością najdłuższy i najbardziej pracochłonny. Dlatego 

zostaną opisane tylko wybrane elementy. Narzędzia i metody modelowania są dla pozostałych obiektów bardzo 

podobne. Warto pamiętać, że nie ma jedynej słusznej drogi dla tworzenia konkretnych modeli. Nawet 

najprostszy sześcian można utworzyć na praktycznie nieskończoną ilość sposobów. Z tego powodu zawsze 

staramy się wybrać metodę najszybszą lub najbardziej dla nas wygodną. Nie oznacza to jednak, że nie istnieje 

inne podobne lub lepsze rozwiązanie. 

4.1.1. Opis okien programu Cinema 4D 

Jedną z największych zalet programu Cinema 4D jest znakomicie zorganizowany interfejs, który dodatkowo 

można w dowolny sposób konfigurować. Przygotowane są również predefiniowane ustawienia w zależności od 

sposobu korzystania z programu. Widok podstawowego okna programu widoczny jest poniżej. 
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Rys. 3. Okno programu Cinema 4D  

Źródło: opracowanie własne 

Main Menu – główne menu programu, pozwala na dostęp do wszystkich trybów, funkcji i narzędzi. Dodatkowo 

możliwe są standardowe operacje zapisu/odczytu plików. 

Viewport – to okno na świat przestrzeni 3D. Możliwe jest przeglądanie widoku w rzucie perspektywicznym lub 

w jednym w wielu rzutów prostych. 

Object Manager – tutaj wyszczególnione są wszystkie obiekty, które dodaliśmy do sceny. Do dyspozycji mamy 

wiele opcji grupujących, filtrujących i wyszukujących obiekty. 

Material Manager – okno służące do zarządzania wszystkimi materiałami w scenie. 

Attributes Manager – wyświetla wszystkie parametry dla zaznaczonych funkcji, obiektów lub narzędzi. 

4.1.2. Przygotowanie środowiska pracy 

Pracę rozpoczęto od zrobienia zdjęcia z programu Google Earth Pro, na którym widoczny jest widok z góry na 

kampus Krakowskiej Akademii. Zdjęcie to podłożono w programie Cinema 4D pod viewport w widoku „top”, 

wykorzystano narzędzie do konfiguracji widoku (Shift+V) i zakładkę „Back”. Po wybraniu odpowiedniego 

zdjęcia należy jeszcze dostosować wymiar obrazka aby odpowiadał on wymiarom rzeczywistym. Do tego celu 

wykorzystałem prostokąt o wymiarach 65 x 18 metrów, który miał odpowiadać jednemu z segmentów budynku 

A (taki pomiar uzyskano z aplikacji Google Earth Pro). Po dostosowaniu wymiaru budynku do sześcianu 

uzyskano obraz, który w przybliżeniu odpowiadał w przestrzeni 3D wymiarom rzeczywistym. Jako jednostkę 

miary dla projektu przyjęto centymetry (jednostki domyślne można zmienić w menu: Edit -> 
Preferences).  
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Rys. 4. Przygotowanie pliku C4D do modelowania kampusu KA - zrzut z programu Cinema 4D 

Źródło: opracowanie własne 

4.1.3. Modelowanie budynków kampusu na przykładzie bryły budynku B 

Program Cinema 4D oprócz niezwykle intuicyjnego i konfigurowalnego interfejsu posiada również mnóstwo 

zdefiniowanych skrótów klawiszowych. Można również praktycznie do każdej funkcji lub narzędzia ustawić 

własne kombinacje klawiszy. Korzystanie z nich znacznie przyspiesza pracę i jest bardzo wygodne. Jednak na 

potrzeby tego projektu będę podawał pełne ścieżki dostępu z menu głównego aby ułatwić czytanie tekstu. 

Niezwykle istotnym elementem ułatwiającym modelowanie są przyciąganie (Snap) oraz kwantyzacja 

(Quantize). Ich ustawienia dostępne są w oknie Attributes menu: Mode -> Modeling. Przyciąganie 

pozwala nam określić czy obiekt (lub krawędź, punkt, poligon) będzie przyciągany gdy znajdzie się blisko 

innego obiektu lub elementu. Kwantyzacja natomiast pozwala nam na precyzyjne przeciąganie, skalowanie lub 

obracanie, ograniczając wartości tych transformacji do określonych przez nas liczb (lub ich wielokrotności). 

Bryła budynku B, a właściwie jej początkowy zarys, powstał z prostopadłościanu stworzonego za pomocą 

obiektów parametrycznych (tzw. prymitywów) dostępnych w menu: Create -> Object -> Cube. 

Domyślnie otrzymujemy sześcian o wymiarach 200x200x200 jednostek (w moim przypadku centymetrów). 

Wymiary obiektu możemy ustalić w oknie Attributes. Dla obiektu Cube dostępne są następujące parametry: 

rozmiar w osi X, Y, Z, liczba segmentów (podziałów) dla każdej osi, zaokrąglenie krawędzi, promień i liczba 

podziałów zaokrąglenia oraz przełącznik umożliwiający otrzymanie osobnych obiektów dla każdego poligonu. 

Po ustawieniu przybliżonych wymiarów (X: 1885 cm, Y: 1150 cm, Z: 6440 cm) zamieniono obiekt 

parametryczny na edytowalny przy pomocy funkcji z menu Mesh -> Conversion -> Make Editable. W 

tym momencie tracimy dostęp do atrybutów parametrycznych obiektu, możemy jednak dowolnie edytować jego 

punkty, krawędzie oraz poligony.  

Knife – czyli po prostu nóż, to narzędzie, które wykorzystano do stworzenia podziałów na sześcianie. W trybie 

poligonów (Tools -> Mode -> Polygons) narzędzie Knife dostępne jest w menu Mesh -> Create 
Tools -> Knife. Posiada ono kilka trybów, do cięcia wykorzystano tryb Plane, który umożliwia cięcie 

poligonów wzdłuż wybranej płaszczyzny. Opcja Cut oraz Spacing umożliwia wykonanie jednocześnie większej 

ilości podziałów o określonej odległości pomiędzy każdym. Wykorzystując różne płaszczyzny wykonałem 

cięcia, które zostaną wykorzystane do stworzenia okien i drzwi budynku.  
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Program Cinema 4D posiada wiele znakomitych narzędzi do tworzenia zaznaczeń. Na obecnym etapie do 

tworzenia zaznaczeń najszybsze będzie uniwersalne narządzie Live Selection, które umożliwia zaznaczenie 

poligonów, krawędzi lub punktów (w zależności od wybranego trybu) poprzez najechanie na element kursorem i 

naciśnięcie lewego klawisza myszki. Kolejny element do zaznaczenia można dodać przytrzymując podczas 

kliknięcia klawisz Shift na klawiaturze, natomiast gdy przytrzymamy klawisz Ctrl na klawiaturze i klikniemy na 

element już zaznaczony odejmiemy go od selekcji. Zasady dotyczące sumowania zaznaczeń są identyczne dla 

wszystkich narzędzi tej grupy. Można również zmienić promień zaznaczenia przy użyciu parametru Radius w 

oknie atrybutów narzędzia.  

Do wykonania ram okiennych wykorzystam dwa narzędzia: Extrude i Extrude Inner.  

Extrude – ekstrudowanie to nadawanie dwuwymiarowym przekrojom głębokości. W programie Cinema 4D 

możemy ekstrudować punkty, krawędzie oraz poligony. Kierunek ekstrudowania wyznaczany jest na podstawie 

normalnej poligonu (lub punktu, krawędzi). Normalna to wektor prostopadły do płaszczyzny, który wyznacza 

kierunek, w którym zwrócony jest poligon. 

Extrude Inner – narzędzie o działaniu podobnym do Extrude. Jednakże, w przeciwieństwie do klasycznego 

ekstrudowania, wybrane poligony wytłacza się do wewnątrz lub ewentualnie na zewnątrz.  

Po wybraniu narzędziem Live Selection wszystkich poligonów, które mają stanowić okna wybieramy 

narzędzie Extrude Inner z menu: Mesh -> Create Tools -> Extrude Inner. W oknie Attributes 

ustawiamy parametr Offset na wartość 5 cm oraz, co bardzo istotne w tym przypadku, odznaczamy domyślną 

opcję Preserve Groups. Pozwoli to aby każdy poligon został potraktowany osobno, zamiast łączenia 

sąsiadujących poligonów w grupy. W ten sposób uzyskujemy ramkę o szerokości 5 cm wokół każdego z 

poligonów, które będą służyły za okno. Utrzymując aktualne zaznaczenie wybieramy narzędzie Extrude z 

menu: Mesh -> Create Tools -> Extrude. W oknie atrybutów ustawiamy Offset na wartość -2,5 cm, co 

powoduje, że wszystkie zaznaczone poligony wciągnięte zostają do środka bryły.  

Wykorzystując narzędzia Knife, Extrude oraz Extrude Inner wykonujemy pozostałe elementy budynku 

takie jak drzwi oraz panele ścienne. Warto na etapie modelowania przygotować zaznaczenia, które później 

wykorzystamy podczas przypisywania materiałów do konkretnych części budynku. Aby zapisać zaznaczenie 

wybieramy funkcję Set Selection z menu: Select -> Set Selection. Cinema 4D tworzy w tej sytuacji 

specjalny Tag selekcji przy pomocy którego możemy szybko przywrócić selekcję lub przypisać jakiś materiał 

tylko do fragmentu obiektu. 

Po wszystkich operacjach otrzymujemy główną bryłę obiektu (Rys. 5).  

 

Rys. 5. Wymodelowana bryła budynku B  

Źródło: opracowanie własne 
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Górną część budynku zdecydowano się utworzyć z osobnego obiektu ponieważ posiada ona inną ilość 

segmentów. Wykorzystano w tym celu Cube o wymiarach (X: 1885 cm, Y: 420 cm, Z: 6440 cm). W oknie 

Attributes dla naszego prostopadłościanu ustawiono ilość segmentów odpowiednio: (X: 38, Y: 1, Z: 128). 

Potrzebne podziały w osi Y postanowiono wykonać przy pomocy narzędzia Knife. Podczas tworzenia tego 

obiektu bardzo przydatne było narzędzie do tworzenia selekcji o nazwie Loop Selection. 

Loop Selection – dostępne w menu: Select -> Loop Selection. Tworzy zaznaczenie poligonów, 

krawędzi lub punktów, które są połączone ze sobą i swoim kształtem przypominają pętlę. 

Pozostałe transformacje bryły wykonano przy pomocy narzędzi Extrude, Extrude Inner oraz Knife. 

 

 

Rys. 6. Wymodelowana druga część budynku B 

Źródło: opracowanie własne 

Kolejnym istotnym elementem są ozdobne elementy z cegły. Wszystkie zostały wykonane przy pomocą bryły 

prostopadłościanu. W przypadkach, które tego wymagały bryły parametryczne były zamieniane na edytowalne i 

modyfikowane przy pomocy narzędzi do cięcia i ekstrudowania. W precyzyjnym pozycjonowaniu elementów 

niezwykle przydatna jest funkcja Snap. Balustrada na balkonie została wykonana przy pomocy narzędzia Atom 
Array. 

Atom Array  - dostępne w menu: Create -> Modeling -> Atom Array. Jest to narzędzie, które tworzy 

Cylinder w miejscu każdej krawędzi i Sferę w miejscu każdego punktu.  

Ustawiając jednakową średnicę zarówno dla sfery jak i dla cylindra uzyskujemy w błyskawiczny sposób 

przestrzenną siatkę obiektu. Do utworzenia barierki wystarczył w tym przypadku odpowiednio pocięty Cube 

oraz modyfikator Atom Array. 
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Rys. 7. Model budynku B z elementami z cegły  

Źródło: opracowanie własne 

Aulę budynku B wykonano przy pomocy bryły parametrycznej o nazwie Cylinder. W oknie Attributes ustalono 

następujące wartości: Radius: 1180 cm, Height: 1000 cm oraz Rotation Segments: 72. Z uwagi na fakt, że 

przekrój auli nie jest okręgiem tylko elipsą należało zmodyfikować utworzony cylinder. Odpowiedni kształt 

uzyskano wpisując w oknie Attributes w zakładce Coord. wartość 1,19 dla skali w osi X. Ścięty kształt dachu 

obiektu uzyskano wykorzystując narzędzie Knife w trybie Line z odznaczoną opcją Visible Only. Cięcie 

zostało wykonane w widoku rzutu prostego Front. Po usunięciu niepotrzebnych punktów i zamknięciu powstałej 

dziury przy pomocy narzędzia Close Polygon Hole otrzymałem bryłę przypominającą aulę budynku B. Do 

wykonania detali posłużyły narzędzia Knife, Extrude, Extrude Inner.  

Close polygon hole – dostępne w menu: Mesh -> Create Tools -> Close Polygon Hole to 

narzędzie, które tworzy poligon zamykający zaznaczoną dziurę w siatce modelu. 

Kolejnym elementem, którego modelowanie warto opisać jest napis Krakowska Akademia. Stelaż napisu został 

utworzony przy użyciu brył prostych. Natomiast sam tekst został wykonany przy użyciu generatora MoText. 

MoText – dostępny w menu: Mograph -> MoText jest to generator ekstrudujący czcionkę należący do 

modułu MoGraph. Umożliwia on wykorzystanie wszystkich zalet modułu Mograph dla stworzonych napisów. 

W przypadku napisu Krakowska Akademia wystarczał sam tekst, pominięto więc opis wszystkich opcji 

dostępnych dla obiektu MoText. W oknie Attributes można zdefiniować Text, wybrać rozmiar i krój czcionki 

oraz opcje akapitu. Dla tego przypadku wybrano czcionkę Aparajita o wysokości 188 cm i głębokości 20 cm.  

Model obiektu zawierał również wiele innych detali, jednak większość z nich została wymodelowana przy 

użyciu prostych brył parametrycznych i podstawowych funkcji modelujących, takich jak Extrude. Warto 

również wspomnieć o narzędziu Bevel, które również było często używane na tym etapie modelowania. Istotne 

z punktu optymalizacji sceny jest korzystanie z instancji. Wszystkie obiekty, które powtarzają się w scenie 

zostały ustawione za pomocą instancji. 

Bevel – dostępne w menu: Mesh -> Create Tools -> Bevel to narzędzie, które przekształca twarde 

krawędzie w ich zaokrąglone, wygładzne, miękkie wersje. Narzędzie to działa odrobinę inaczej dla każdego z 

trybów (poligony, krawędzie, punkty), jednak w każdym przypadku daje bardzo duże możliwości uzyskania 

wymaganego zaokrąglenia. 

Instance – dostępne z menu: Create -> Modeling -> Instance to kopia obiektu (lub grupy 

obiektów), która nie posiada własnej geometrii. Tego typu duplikacja pozwala na rozmieszczenie wielu kopii 
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bez zwiększania rozmiaru pliku. Dodatkowo, gdy edytujemy w jakikolwiek sposób obiekt referencyjny 

automatycznie zostaną zaktualizowane wszystkie klony.   

 

Rys. 8. Model budynku B z napisem reklamowym oraz aulą 

Źródło: opracowanie własne 

Pozostałe budynki zostały wymodelowane w podobny sposób. Warto zwrócić uwagę na fakt, że główny segment 

budynku B jest taki sam jak jeden z segmentów budynku A. Natomiast drugi segment budynku A stanowi 

odbicie lustrzane segmentu budynku B. Znacznie uprościło to proces modelowania ponieważ można było 

częsciowo wykorzystać gotowe już elementy. Do utworzenia odbicia lustrzanego posłużyło narzędzie 

Symmetry.  

Symmetry – dostępne w menu: Create -> Modeling -> Symmetry pozwala utworzyć odbicie lustrzane 

obiektu względem wybranej osi. Jest to bardzo przydatne np. gdy modelujemy skomplikowany symetryczny 

obiekt (np. samochód) gdyż pozwala nam wymodelować tylko połowę obiektu.  

Do wykonania bryły budynku C również użyłem prostopadłościanu z odpowiednią ilością segmentów. Aby 

wykonać zakrzywioną linię wykorzystałem narzędzie z grupy deformerów o nazwie Bend.  

Bend – dostępny w menu: Create -> Deformer -> Bend umożliwia wyginanie obiektów. Promień zagięcia 

jest zależny od rozmiaru i położenia deformera. Oczywiście dla jednego obiektu można użyć kilku deformerów. 

Aby móc dalej edytować zakrzywioną już bryłę użyłem funkcji Current State to Object. Pozostałe 

transformacje zostały wykonane przy użyciu standardowych narzędzi do modelowania. 

Current State to Object – dostępne w menu: Mesh -> Conversion -> Current State to 
Object to narzędzie, które wykonuje edytowalną kopię obiektu z uwzględnieniem wszelkiego rodzaju 

deformerów. 
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Rys. 9. Widok na wymodelowany kampus Krakowskiej Akademii  

Źródło: opracowanie własne 

4.1.4. Modelowanie terenu kampusu Krakowskiej Akademii 

Teren kampusu Krakowskiej Akademii na potrzeby projektu postanowiono wymodelować w pewnym 

uproszczeniu. Mimo wszystko było to zagadnienie dosyć złożone, wymagające przemyślanego podejścia, przede 

wszystkim ze względu na znaczne różnice wysokości.  

Przed rozpoczęciem modelowania sporządzono rysunek, który w sposób uproszczony przedstawiał różnice 

wysokości pomiędzy poszczególnymi punktami na terenie kampusu. Jako poziom zero przyjęto najwyższy punkt 

czyli dziedziniec pomiędzy budynkami A oraz B. Pozostałe wartości to różnica w odniesieniu do punktu zero, 

podawana w centymetrach. Wszystkie wartości określono na podstawie zdjęć i zaokrąglono dla ułatwienia do 

pełnych wartości. Z pewnością są one obarczone błędem pomiarowym, nie powinno to jednak mieć żadnego 

znaczenia dla odbioru wizualizacji.  
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Rys. 10. Schematyczna mapa wysokości terenu Krakowskiej Akademii 

Źródło: opracowanie własne 

Podstawą modelu terenu została jedna z brył prostych, a mianowicie Plane złożony dla uproszczenia z tylko 

jednego poligonu. 

Plane – dostępny w menu: Create -> Object -> Plane to po prostu płaszczyzna o dowolnie 

definiowalnej ilości segmentów. 

Rozmiar płaszczyzny ustawiono aby zakrywał zdjęcie podłożone pod widok z góry a jej pozycję na 0. Następnie 

zamieniono obiekt na edytowalny (Make Editable) wykonałem podstawowe cięcia w osi X. Kolejno 

zaznaczono wszystkie punkty dla danej linii i ustalono ich wysokość zgodnie z powyższym rysunkiem. Dzięki 

temu uzyskano obiekt, który posiadał zróżnicowanie wysokości tylko wzdłuż osi Z. Linie powstałe w wyniku 

cięcia narzędzie Knife dopasowano do podłożonego zdjęcia. Następnie wykonano zaledwie kilka cięć w osi Z, 

aby dopasować zróżnicowanie wysokości również wzdłuż osi Y. Tak przygotowany model był idealną bazą do 

wykonywania kolejnych cięć w celu utworzenia np. jezdni i chodników ponieważ zawierał łagodne przejścia z 

jednej wysokości do drugiej. Na poniższym rysunku przedstawiono etapy prac nad modelem terenu. Do 

wykonania wszystkich transformacji posłużyło narzędzie Knife, Move oraz różne narzędzia do zaznaczania 

punktów. 
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Rys. 11. Etapy wykonywania cięć modelu terenu wokół Krakowskiej Akademii 

Źródło: opracowanie własne 

Tak wykonany model zmodyfikowano jeszcze przy pomocy Extrude aby uzyskać głębokość chodników, 

natomiast Extrude Inner posłużył do wykonania krawężników. Zaznaczenia poligonów potrzebne w 

późniejszym etapie do modelowania były zapisywane na bieżąco. 

4.1.5. Wypełnianie sceny gotowymi modelami 

Podczas modelowania tak obszernej sceny dobrym pomysłem jest tworzenie poszczególnych elementów w 

osobnych plikach. Modelowanie zawsze prostsze jest w środku sceny, ponieważ domyślnie tam wstawiane są 

wszystkie obiekty. Również sama nawigacja jest dużo prostsza w centrum wirtualnej przestrzeni. Po wykonaniu 

modelu można go wstawić do gotowej sceny i przesunąć w odpowiednie miejsce. Bardzo skomplikowane sceny 

mogą być bardzo obszerne jeżeli chodzi o przestrzeń zajmowaną na dysku twardym. Cinema 4D oferuje 

narzędzie, które potrafi rozwiązać ten problem. 

XRef – dostępny w menu: Create -> XRef  -> Add XRef to obiekt zawierający referencję do innego pliku 

projektu, który możemy zawrzeć w naszej scenie. Zmniejsza to ilość danych zapisywanych na dysku twardym w 

przypadku tworzenia kolejnej wersji zapisu oraz ułatwia pracę nad jednym projektem w kilka osób. 

Obiekt referencyjny został przeze mnie wykorzystany również po to, aby wyraźnie oddzielić obiekty 

wymodelowane w całości przeze mnie oraz te pobrane z Internetu lub biblioteki zasobów programu Cinema 4D. 

Były to drzewa i inne rośliny oraz samochody ponieważ ich modelowanie byłoby zbyt pracochłonne a nie 

odgrywają one pierwszoplanowej roli w tym projekcie. 

4.2.  Teksturowanie 

Teksturowaniem na potrzeby tego projektu będzie określane zarówno przygotowywanie map w programie 

Photoshop jak i późniejsze tworzenie shaderów Vray i przypisywanie ich do konkretnych obiektów. Jest to etap 

bardzo mocno powiązany z oświetleniem i renderingiem, dlatego przed rozpoczęciem prac nad materiałami 

wykonałem wstępne ustawienia renderingu i wstawiłem do sceny światło. Jest to konieczne aby móc podglądać 

efekty pracy w trakcie tworzenia w warunkach zbliżonych do efektów końcowych 

4.2.1. Przygotowywanie tekstur w programie Photoshop 

Mapy w postaci rastrowych plików graficznych są jednym z najlepszych sposobów uzyskiwania realistycznych 

materiałów w programie do grafiki 3D. Aby bez problemów korzystać z nich w przestrzeni 3D warto zadbać aby 

były odpowiednio spreparowane. Przede wszystkim warto zadbać o możliwość bezproblemowego powielania 
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grafiki bez widocznych połączeń pomiędzy brzegami obrazka. Niestety nie każde zdjęcie nadaje się do takiego 

zabiegu. Istnieją jednak techniki, które ułatwiają tworzenie powtarzalnych tekstur. Część z nich zostanie 

przedstawiona na przykładzie materiału cegły. 

Cegły, które zostały wykorzystane do ozdobienia elewacji Krakowskiej Akademii są na tyle wyjątkowe, że 

zostały sfotografowane  i teksturę wykonanona podstawie tego zdjęcia. Poniżej widoczne jest zdjęcie, które 

wykorzystano do stworzenia tekstury.  

 

Rys. 12. Zdjęcie przedstawiające elewację Krakowskiej Akademii 

Źródło: opracowanie własne 

Na fotografii widać zniekształcenie spowodowane przez obiektyw aparatu fotograficznego. Zauważalna jest 

również niejednolita jasność zdjęcia co będzie utrudniało wykonanie tekstury powtarzalnej. Słabo widoczne są 

cienie co akurat jest bardzo korzystne.  

Lens Correction – dostępne w menu: Filter -> Lens Correction aplikacji Adobe Photoshop CS6 to 

narzędzie, które umożliwiło usunięcie efektu dystorsji. Głównym parametrem pozwalającym na jego eliminację 

jest Remove Distortion. Wartość około + 8 wyeliminowała problem. Potrzebna była również delikatna korekta 

perspektywy zarówno w pionie, jak i w poziomie za pomocą opcji dostępnych w narzędziu Lens Correction. 

Kolejnym etapem było przycięcie obszaru roboczego przy użyciu narzędzia Crop. Istotne było przycięcie w taki 

sposób aby po powtórzeniu tekstury cegły miały odpowiednie wymiary. Następnie użyłem funkcji Offset z 

menu: Filter -> Other -> Offset. Otrzymałem w ten sposób mniej więcej na środku obrazu poziomą i 

pionową linię łączącą dotychczasowe brzegi tekstury. Przy użyciu narządzia Clone Stamp Tool 

wyeliminowałem wszelkie widoczne ślady połączenia. W tym momencie testura jest już w pełni powielalna 

jednak dla lepszego efektu wykonałem kilka dodatkowych kroków aby w największym możliwym stopniu 

usunąć niepotrzebne zmiany tonacji spowodowane przez cienie lub odbłyski. W tym celu najpierw 

zduplikowałem aktualną warstwę. Z menu: Filter -> Other -> High Pass uzyskałem dostęp do filtra 

High Pass, ustaliłem wartość na około 80 i zatwierdziłem.  Następnie wybrałem w menu: Image -> Fade 
High Pass, zmieniłem na tryb Luminosity i potwierdziłem przyciskiem OK. Po scaleniu dwóch obydwu 

aktualnych warstw otrzymałem teksturę, której ogólna jasność jest zróżnicowana i można ją bez problemów 

powielać. Zostanie ona wykorzystana dla kanału Diffuse czyli w dużym uproszczeniu koloru bazowego 

materiału.  

Aby w pełni wykorzystać możliwości nowoczesnych shaderów silnika renderującego Vray postanowiono 

również utworzyć osobne tekstury dla kanałów Specular, Bump, Displacement. 
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Specular – to kanał odpowiedzialny za tworzenie odbić i refleksów. Jednak w przypadku ściany z cegieł połysk 

nie jest jednolity na całej powierzchni. Takie zróżnicowanie możemy uzyskać przy pomocy odpowiedniej mapy 

(tekstury). 

Bump – kanał odpowiedzialny za tworzenie efektów wypukłości/chropowatości jednak w przeciwieństwie do 

innych metod nie modyfikuje w żaden sposób aktualnej geometrii obiektu.  

Displacement – to w przypadku Vray’a oddzielny rodzaj shadera, który również umożliwia tworzenie 

wypukłości i chropowatości modyfikując przy tym aktualną geometrię obiektu. Tworzone są również dodatkowe 

podziały każdego poligonu aby zapewnić wystarczającą ilość podziałów. Oczywiście zwiększa to czas 

renderingu.  

Tekstury dla poszczególnych kanałów uzyskano poprzez modyfikację tekstury bazowej. Najwięcej pracy 

wymagała mapa Displacement. Aby uzyskać najlepsze rezultaty przy pomocy narzędzia selekcji Color Range 

wyodrębniłem fugę, zaznaczenie poprawiono przu użyciu opcji Refine Edge. Rozdzielono cegły od fugi na 

osobne warstwy i dopasowano ich jasność za pomocą warstw dopasowania Levels. Bump został pozyskany z 

tekstury Diffuse przy pomocy warstw dopasowania Levels, Curves oraz Hue/Saturation. Mapa Specular 

powstała z przyciemnienia mapy Bump za pomocą warstwy dopasowania Curves. Poniżej gotowe mapy bitowe 

do zastosowania w materiale cegły. 

 

Rys. 13. Przygotowane tekstury dla materiału cegły 

Źródło: opracowanie własne 

4.2.2. Projekcja (mapowanie) materiałów 

Projekcją lub mapowaniem tekstury nazywamy odzwierciedlenie dwuwymiarowej tekstury (lub 

trójwymiarowego proceduralnego shadera) na powierzchnię obiektu 3D. W Cinema 4D dostępne są różne 

metody projekcji materiałów, które pozwalają szybko i skutecznie uzyskać wymagane rezultaty. Jedną z metod 

jest nałożenie tekstury na jedną z brył prostych a następnie odwzorowane na obiekt 3D.  

Spherical – tekstura nakładana jest na kulę i rzutowana na obiekt 3D. Bardzo często wykorzystywany dla 

obiektów o kształcie sferycznym. 

Cylindrical - – tekstura nakładana jest na walec i rzutowana na obiekt 3D, najczęściej wykorzystywany dla 

obiektów o kształcie zbliżonym do walca. 

Flat – tekstura nakładana jest na płaszczyznę i rzutowana na obiekt 3D. Bardzo użyteczny tryb dla wszelkiego 

rodzaju obiektów, w których występują płaskie powierzchnie. 

Cubic – tekstura nakładana jest na sześcian i rzutowana na obiekt 3D. Niezwykle użyteczny tryb ponieważ w 

większości przypadków pozwala w błyskawiczny sposób uzyskać odpowiednie rozłożenie materiału.  
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Spatial – mapowanie bardzo podobne do trybu flat, jednak tekstura jest przesuwana w górę i lewą stronę w 

przestrzeni obiektu. Pozwala uzyskać dobre rezultaty dla materiałów proceduralnych, takich jak np. marmur. 

Shrink Wrapping – metoda polegająca na przymocowaniu środka tekstury do „bieguna północnego” sfery i 

następnie rozciągnięcie tekstury na kulę. Zaletą tego trybu jest widoczny szew jedynie w punkcie „bieguna 

południowego” kuli. Wykorzystywany jest jedynie wycinek tekstury w postaci koła, którego środek jest w 

punkcie środkowym tekstury, pozostała część jest odrzucana. 

Frontal – tekstura jest rzutowana zgodnie z położeniem kamery, przez, którą patrzymy w przestrzeń 3D. Tryb 

najczęściej wykorzystywany do compositingu, na przykład przy wklejaniu obiektów 3D na zdjęcie. 

Camera Mapping – tryb bardzo podobny do trybu frontal, jednak w przeciwieństwie do niego tekstura może 

zostać zablokowana i rzutowana tylko z konkretnego widoku kamery. 

UVW Mapping – Mapowanie UV jest to technika polegająca na przetransformowaniu siatki obiektu na obraz 

2d i przypisaniu wierzchołkom obiektu współrzędnych (U, V), które odpowiadają współrzędnym tekstury. Jest 

to metoda , która pozwala uzyskać najlepsze rezultaty, wymaga jednak najwięcej pracy. 

4.2.3. Tworzenie shaderów 

Mapy w postaci rastrowych plików graficznych są jednym z najważniejszych czynników potrzebnych do 

uzyskania ciekawych, zróżnicowanych i realistycznych shaderów. Istotne jest również właściwe wykorzystanie 

dostępnych w oprogramowaniu opcji. Silnik renderujący Vray pozwala uzyskać świetne rezultaty gdy staramy 

się odwzorować materiały i shadery zgodnie z ich naturalną budową w świecie rzeczywistym.  

VrayForC4D posiada kilka rodzajów shaderów, jednak w większości przypadków korzysta się z 

VRayAdvancedMaterial.  

VRayAdvancedMaterial – dostępny w menu TextureManager: Create -> Shader -> VrayBridge -> 
VRayAdvancedMaterial. Jest to podstawowy typ materiału, który udostępnia bardzo szerokie możliwości. 

Stworzony jest na bazie kanałów, które nakładane są na siebie w podobny sposób jak warstwy w Adobe 

Photoshop. Dostępne są następujące kanały: 

Material Matte – kanał ułatwiający zezwętrzny compositing np. w Adobe After Effects. Można dzięki niemu 

tworzyć różnego rodzaju maski i zaznaczenia. 

Material Weight – można go w uproszczeniu nazwać kanałem Alpha, jednak umożliwia bardziej 

zaawansowane możliwości ustawienia przezroczystości materiału i łączenia z innymi materiałami Vray. 

Bump – to kanał umożliwiający dodawanie wypukłości i innych szczegółów do materiału bez konieczności 

modelowania ich. W polu Map Type mamy możliwość wyboru pomiędzy zwykłym obrazem w skali szarości lub 

Normal Mapą w różnych przestrzeniach.  

Luminosity Layer – kanał ten umożliwia nadanie materiałowi właściwości emisji światła. Możemy w ten 

sposób rozjaśnić obiekt, sprawić, że będzie widoczny nawet bez jakichkolwiek świateł w scenie lub nawet 

oświetlać scenę przy użyciu takiego materiału.  

Flakes Layer – kanał umożliwiający dodanie drobinek ziarna, podobnie jak w bazowym perłowym lakierze 

samochodowym.  

Specular Layer – jest to obok kanału Diffuse jeden z najczęściej wykorzystywanych kanałów. Umożliwia 

tworzenie zarówno realistycznych odbić materiałów, jak i tradycyjnych „oszukanych” połysków. Standardowo 

mamy do dyspozycji 5 kanałów Specular Layer, które możemy dowolnie warstwować. W większości 

przypadków wystarcza jeden kanał odbicia. Do dyspozycji mamy różne typy odbić, konrolę nad kolorem,  

szorstością i przezroczystością odbicia. Przezroczystość odbicia możemy również uzależnić od indeksu refrakcji 

IOR materiału co ułatwia tworzenie fizycznie akuratnych materiałów. 

Diffuse Layer – to w dużym uproszczeniu kolor bazowy materiału. Mamy do dyspozycji dwa kanały Diffuse, 

które możemy dowolnie mieszać pomiędzy sobą za pomocą zakładki Diffuse Layer Transparency. Oczywiście 

możemy wykorzystywać dowolne tekstury w postaci plików graficznych lub proceduralnych shaderów i efektów 

Vray lub Cinema 4D. Dostępna jest również opcja VrayDirt do tworzenia zanieczyszczeń na krawędziach.  

Refraction Layer – jest to kanał służący do tworzenia wszelkiego rodzaju przezroczystych i przepuszczających 

obiektów. Istnieje możliwość wpisywania realnych fizycznych wartości IOR. 
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SSS Layer – czyli Subsurface Scattering to kanał umożliwiający tworzenie materiałów takich jak np. skóra 

ludzka, gdzie występuje efekt przenikania światła przez powierzchnię. 

4.2.3.1. Shader cegły 

Tworzenie materiałów w praktyce zostanie zaprezentowane na podstawie shadera cegły. Podstawą do stworzenia 

tego materiału był opisany powyżej Vray Advanced Material. W kanale Diffuse1 zastosowano przygotowaną 

wcześniej w Adobe Photoshop mapę Diffuse. Aby efekt koloru nie był zbyt jednostajny postanowiono zmieszać 

ją z efektem shader Cinema 4D Noise. Shader ten umożliwia tworzenie parametrycznych i w pełni 

proceduralnych map. Wykorzystano Noise o nazwie Gaseous, skalę globalną ustawiono na 50000%, pozostałe 

parametry pozostały domyślne. Pozwoliło to stworzyć czarno białą mapę, generowaną proceduralnie, która nie 

będzie powtarzalna bez względu na projekcję materiału. Aby połączenie mapy bitowej i shadera Noise było 

możliwe i w pełni proceduralne wykorzystałem shader Cinema 4D Layer. Tworzy on warstwy, które podobnie 

jak w programie Photoshop można dowolnie mieszać pomiędzy sobą. W tej sytuacji shader Noise ułożono nad 

mapą Diffuse i ustawiłem Blending Mode na Overlay i Opacity na 15%. Efektem jest delikatne zróżnicowanie 

koloru na powtarzanej teksturze cegły.  

Kolejnym wykorzystanym kanałem jest Specular Layer 1. W zakładce Specular Color wykorzystano utworzoną 

wcześniej mapę Reflection, jako Specular Color Transparency ustawiono Fresnel IOR o wartości 1,6 i parametr 

Reflection Glossiness na wartość 0,86. Pozwoliło to uzyskać bardzo delikatny połysk, odpowiedni dla cegły. 

Kanał Bump wypełniono przy pomocy przygotowanej tekstury, jako wartość wypukłości wpisałem 0,5 cm. 

Tak stworzony materiał odpowiedni jest dla ujęć z pewnej odległości oraz dla animacji ponieważ szybkość 

renderingu jest bardzo dobra. Dla uzyskania lepszych efektów np. dla zbliżeń warto wykorzystać jako dodatek 

stworzoną wcześniej mapę Displacement, która pozwala stworzyć wypukłości modyfikując aktualną geometrię 

obiektu. W przypadku VrayforC4D tego typu wypukłości tworzymy poprez specjalny shader Vray Displace 

Material dostępny w menu TextureManager: Create -> Shader -> VrayBridge -> 
VrayDisplaceMaterial. Istotne jest aby shader  VrayDisplaceMaterial znajdował się pod 

VrayAdvancedMaterial aby nie nadpisał pozostałych atrybutów materiału. Oczywiście powinien mieć takie 

same parametry mappingu tekstury jak podstawowy shader cegły. 

 

Rys. 14. VrayAdvancedMaterial oraz VrayDisplaceMaterial dla materiału cegły 

Źródło: opracowanie własne 

4.3.  Oświetlenie 

VrayForC4D oferuje duże możliwości użycia różnego rodzaju świateł do oświetlenia sceny. W przypadku tej 

pracy wykorzystano znakomicie zaimplementowany zestaw jakim jest Vray Physical Sun & Sky. Aby 

utworzyć ten system należy najpierw dodać do sceny Infinite Light dostępny w menu: Create -> Light -> 
Infinite Light. Następnie na tak utworzone światło dodano Vray Light Tag. Aby to zrobić należy 

zaznaczyć utworzone światło w Object Manager i wybrać z jego menu: Tags -> VrayBridge_Tags -> 
VrayLight. W ten sposób automatycznie otrzymujemy dostęp do menu światła Vray, panel ten dostępny jest w 

Attributes Manager. W pierwszej kolejności zaznaczono opcję Enable Shadows, ponieważ z nieznanych mi 

przyczyn domyślnie światła nie posiadają cieni.  
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Vray Physical Sun & Sky zostały stworzone aby współpracując razem odtworzyć warunki oświetlenia 

jakie panują na naszej planecie w rzeczywistości. Intensywność i kolor światła zależny jest od kąta nachylenia 

Infinite Light do podłoża i odpowiada rzeczywistym parametrom słońca np. w przypadku wschodu i zachodu 

słońca. Dostępne są również różne modele nieba np. bezchmurnego lub o dużym zachmurzeniu.  

Jest to znakomite rozwiązanie zarówno dla wnętrz jak i renderingów architektonicznych. Pomimo prostoty 

generuje znakomite rezultaty. Na potrzeby projektu wykorzystano VrayLight o kącie nachylenia -33.122 ° i 

modelu bezchmurnego nieba CIE Clear Sky. Uzyskano w ten sposób piękną i słoneczną atmosferę idealnie 

pasującą do mojej wizji wyglądu projektu.  

 
Rys. 15. Atrybuty VrayLight. 

Źródło: opracowanie własne. 

4.4.  Kompozycja 

Kompozycja jest bardzo istotnym elementem wykonywania wizualizacji. Podobnie jak w innych sztukach 

wizualnych, takich jak film, malarstwo i fotografia, nasze oczy podświadomie szukają tzw. mocnych punktów. 

Ważne jest więc, aby te preferencje wykorzystać odpowiednio kadrując zdjęcie co uczyni pracę bardziej 

atrakcyjną w odbiorze.  

Podstawową zasadą kompozycji w fotografii jest reguła trójpodziału. Ekran dzielony jest w niej na dziewięć 

części przy pomocy dwóch pionowych i dwóch poziomych linii. Mocne punkty kadru znajdują się na 

przecięciach linii, horyzont naszego obrazu najlepiej umieścić równo z jedną z linii poziomych. 

Istnieją również inne metody kompozycji, które przedstawione są na ilustracji poniżej. 
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Rys. 16. Zasady kompozycji w fotografii 

Źródło: http://fotoinformator.pl/foto/2014/07/kompozycja-w-fotografii-podzia%C5%82y.jpg 

Zastosowanie się do jednej z powyższych reguł znacząco wpływa na odbiór zdjęcia jak i wizualizacji, nie 

oznacza to jednak, że zawsze należy się ich bezwzględnie trzymać. W pracy korzystano najczęściej z zasady 

trójpodziału. 

4.4.1. Aparat fotograficzny w przestrzeni 3D 

Tworzenie zdjęć w przestrzeni 3D, zwłaszcza przy użyciu takiego silnika renderującego jak VRay, podlega 

podobnym zasadom jak wykonywanie fotografii. Do tego celu służy Tag VrayPhysicalCamera, który należy 

umieścić na standardowej kamerze Cinema 4D.  

http://fotoinformator.pl/foto/2014/07/kompozycja-w-fotografii-podzia%C5%82y.jpg
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Rys. 17. Atrybuty VrayPhysicalCamera. 

Źródło: opracowanie własne. 

Kluczowymi atrybutami są tutaj oczywiście ustawienia ekspozycji fotografii, czyli wartości przysłony (F-Stop), 

czasu naświetlania (Shutter speed) oraz czułości (Film ISO). W większości wykonanych wizualizacji parametry 

te były podobne i wynosiły odpowiednio: Film ISO: 100, F-Stop: 8, Shutter Speer: 200 (odpowiednik 1/200 s). 

Oprócz ustawień podstawowych VrayPhysicalCamera udostępnia wiele dodatkowych funkcji i efektów 

takich jak dystorsja, winietowanie, rozmycie ruchu lub głębia ostrości. Dodawanie do wizualizacji zniekształceń 

i innych niekoniecznie pożądanych w fotografii elementów jest szeroko stosowane w celu zwiększenia realizmu 

wizualizacji. 

Kolejnym bardzo istotnym elementem fotografii zarówno w życiu realnym jak i w przestrzeni 3D jest ogniskowa 

obiektywu, od której zależy kąt widzenia kamery. Ustawienia te w Cinema 4D dostępne są w atrybutach obiektu 

Camera.  
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Rys. 18. Atrybuty kamery Cinema4D. 

Źródło: opracowanie własne. 

4.5.  Animacja 

Tworzenie animacji komputerowych w programie Cinema 4D jest niezwykle rozbudowane. Otrzymujemy 

zarówno ergonomiczne rozwiązania do tworzenia najprostszych animacji kluczowanych, generatory animacji 

bez kluczowania jak i zaawansowane narzędzia do animacji postaci.  

4.5.1. Animacja kamery (Camera Morph). 

Animacja w tym projekcie z uwagi na ograniczenia czasowe jak i sprzętowe ograniczona została wyłącznie do 

animacji kamery. Jest to zabieg często spotykany w przypadku animacji architektonicznych, również ze względu 

na uproszczenia w obliczaniu globalnej iluminacji dla sceny.  

Poruszanie kamerą w Cinema 4D wymaga kluczowania jej pozycji oraz rotacji. Nie jest to co prawda 

skomplikowane i można to zrobić jednym kliknięciem ale korygowanie i poprawianie animacji, gdy kluczy w 

scenie jest już dużo może być zajęciem żmudnym. Dodatkowo łatwo jest o pomyłkę. Cinema 4D posiada jednak 

narzędzie, które w znacznym stopniu ułatwia tego typu animacje.  

CameraMorph – dostępny w menu Create -> Camera -> CameraMorph to tag, który umożliwia 

interpolacje pomiędzy dwoma (lub więcej) innymi kamerami. Jako źródło możemy ustawić dowolne kamery w 

scenie, parametr Blend odpowiada za przejście z jednej kamery do drugiej. Cinema 4D samodzielnie interpoluje 

ruch i obrót kamery, a także takie parametry jak ogniskowa i punkt ostrości. W przypadku prostej animacji 

zazwyczaj nie ma potrzeby stosowania funkcji MultiMorph, która pozwala przełączać się pomiędzy dowolną 

liczbą kamer. W każdej chwili możemy również skorygować ustawienie kamer źródłowych bez potrzeby zmiany 

jakichkolwiek klatek kluczowych animacji. Jako kamerę źródłową możemy również wykorzystać animowaną 

wcześniej kamerę.  
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Rys. 19. Atrybuty CameraMorph tag. 

Źródło: opracowanie własne. 

Wszystkie wykonane ujęcia w tej pracy zostały zrealizowane przy pomocy prostych CameraMorph 

składających się z kamery początkowej i końcowej. W związku z powyższym całkowita ilość klatek kluczowych 

w projekcie wyniosła zaledwie 43 co jest bardzo niskim wynikiem przy tak długiej animacji. 

4.6.  Ustawienia silnika renderującego 

Ustawienia silnika renderującego mają decydujący wpływ na jakość ale przede wszystkim na szybkość renderu. 

W przypadku wizualizacji i animacji architektonicznych odpowiednia równowaga pomiędzy prędkością i 

zadowalającym efektem jest bardzo istotna.  

Ustawienia renderingu dostępne są w menu: Render -> Edit Render Settings. Zostały one podzielone 

na kilka kart i zakładek.  
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Rys. 20. Ustawienia renderingu Cinema 4D. 

Źródło: opracowanie własne. 

Pierwsza opcja pozwala nam wybrać z listy rozwijanej silnik renderujący, z którego korzystać będziemy do 

wykonywania renderów. Wybranie opcji VrayBridge dodaje na końcu listy kartę z ustawieniami silnika Vray. 

Niektóre z kart są nieistotne w przypadku wyboru zewnętrznego silnika renderującego i pominę je w opisie. 

Output – w tym miejscu można ustalić najważniejsze parametry tworzonych plików, takie jak rozdzielczość 

renderu, frame rate oraz zakres renderowanych klatek animacji. 

Save – nie tylko pozwala określić w jakim miejscu zostaną zapisane wyrenderowane pliki ale także w jakim 

formacie 

MultiPass – pozwala zapisać selektywnie różnego rodzaju kanały obrazu (np. światła, cienie, odbicia) lub 

warstwy specjalne (np. selekcja obiektu) przydatne do postprodukcji lub compositingu.  

VrayBridge – tutaj umieszczone są wszystkie ustawienia dotyczące silnika renderującego Vray. Wielokrotnie 

właśnie ten aspekt jest wymieniany jako główna wada silnika Vray, ponieważ mnóstwo zakładek, opcji, 

przycisków i przełączników odstrasza początkujących użytkowników. Patrząc na to z drugiej strony 

otrzymujemy zdecydowanie większe możliwości kontroli nad parametrami renderingu. Na potrzeby tego 

projektu skupię się na najważniejszych parametrach, które znajdują się w zakładkach Antialiasing oraz Indirect 

Illumination (GI) . 

Antialiasing (w skrócie AA) - to część silnika, która odpowiada za wygładzanie krawędzi wokół wysoko 

kontrastowych regionów renderowanego obrazu (np. krawędzie geometrii modelu lub tekstury). W silniku Vray 

dostępne jest kilka samplerów AA, na potrzeby tego projektu używałem Adaptive DMC Sampler. Jego praca jest 

zależna  od ilości podziałów (subdivisions) dla elementów składowych sceny, takich jak światła, globalna 

illuminacja, materiały. Im mniej subdywizji tym więcej szumów w scenie, lecz jednocześnie rendering jest 

szybszy. Duży szum jednak powoduje zwiększenie ilości pracy dla samplera AA, co powoduje wzrost czasu 

renderingu. Dlatego znalezienie właściwej równowagi pomiędzy ilością subdywizji a samplerem AA jest 

kluczowym czynnikiem pozwalającym uzyskanie renderingu akceptowalnej jakości w rozsądnym czasie.  
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Indirect Illumination (GI) – inaczej globalna illuminacja, to model oświetlenia, który odpowiada za 

rozprowadzenie światła odbitego w scenie. System ten pozwala na uzyskanie o wiele bardziej realistycznych 

efektów niż przy wykorzystaniu jedynie światła bezpośredniego. Vray oferuje kilka algorytmów oraz możliwość 

wykorzystania jednocześnie dwóch z nich dla lepszych efektów.  Na potrzeby projektu korzystałem z Irradiance 

Map oraz Light Cache. 

4.7.  Postprodukcja 

Postprodukcja to ogół działań podejmowanych po renderingu w celu korekty obrazu. Jej znaczenie jest dosyć 

istotne, ponieważ możliwości jakie oferują programy do postprodukcji są ogromne i ich użycie może całkowicie 

zmienić wygląd końcowy obrazu. Niektóre efekty, które są trudne lub nawet niemożliwe do uzyskania 

bezpośrednio w renderingu 3D można wytworzyć szybko i bezproblemowo w postprodukcji. W moim 

przypadku korekty przede wszystkim będą wykonywane odnośnie jasności i korekty kolorystycznej.  

4.7.1. Postprodukcja wizualizacji w Adobe Photoshop CS6 

Pracę w programie Adobe Photoshop CS6 zostanie opisana na podstawie jednej z wizualizacji, ponieważ zakres 

prac we wszystkich przypadkach był podobny. 

 

Rys. 21. Porównanie wizualizacji przed i po postprodukcji. 

Źródło: opracowanie własne. 

Rendering wykonany w programie Cinema 4D, widoczny po lewej stronie, jest dosyć ciemny. Zwracają również 

uwagę brakujące fragmenty powierzchni. Do uzupełnienia braków wykorzystano teksturę trawy z projektu, 

wymagała ona jednak korekty kolorystycznej przy użyciu warstwy dopasowania Hue/Satruration 

(Barwa/Nasycenie). Dopasowanie do odpowiedniej perspektywy wykonałem przy użyciu narzędzia Skew 

dostępnego w menu: Edit -> Transform -> Skew. W kolejnym etapie przy użyciu warstwy dopasowania 

Curves oraz maski przyciemniono dach, oraz dodano do niego delikatne zróżnicowanie przy użyciu tekstury. 

Następnie również przy użyciu krzywych dopasowano jasność, oraz kontrast obrazu. Dodano również delikatny 

blask od strony źródła światła oraz więcej odbicia w szybach przy użyciu dodatkowej warstwy renderingu. Na 

koniec podniesiono wartość ekspozycji w centralnej części obrazu. 

4.7.2. Montaż animacji w programie Adobe After Effects CS6 

Program Adobe After Effects CS6 to pakiet o sporych możliwościach nastawiony przede wszystkim na 

postprodukcję i efekty specjalne w klipach filmowych. Możliwości są naprawdę spore, włączając w to również 

grafikę 3D. W tej pracy wykorzystano go jednak tylko do montażu i delikatnej korekcji kolorów oraz podłożenia 

ścieżki dźwiękowej. 

Zasada działania Adobe After Effects jest bardzo podobna do działania Adobe Photoshop. Również mamy do 

dyspozycji warstwy, efekty i różnego rodzaju presety. Podstawą każdego projektu są jednak kompozycje, które 

można dowolnie w sobie zagnieżdżać.  

Wyrenderowana animacja składa się z piętnastu ujęć o długości od 150 do 450 klatek. Łącznie daje to 2700 

klatek czyli 108 sekund przy prędkości odtwarzania 25 klatek na sekundę.  

Takie parametry wybrano tworząc nową kompozycję z menu Composition -> New Composition. 

Następnie zaimportowano wszystkie animacje wykorzystując polecenie z menu: File -> Import -> File. 

Poszczególne elementy przeniesiono i ustawiono w odpowiedniej kolejności w linii czasu za pomocą systemu 

przeciągnij i upuść.  

Napisy początkowe zostały utworzone w kolejnej kompozycji. Tekst został dodany przy użyciu polecenia z 

menu Layer -> New -> Text. Do animacji tekstu zostały wykorzystane wbudowane schematy animacji. 
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Pojawianie się liter zrealizowano przy pomocy efektu Slow Fade On dostępnego w menu: Effects & 
Presets -> Animation Presets -> Text -> Animate In -> Slow Fade On. Znikanie to 

analogiczny efekt dostępny w menu: Effects & Presets -> Animation Presets -> Text -> 
Animate Out -> Fade Out Slow.  

Trzecia kompozycja została utworzona w celu połączenia dwóch poprzednich. W kompozycji tej na spodzie 

zostało dodane czarne tło przy pomocy polecenia: Layer -> New -> Solid. 

Rendering animacji został wykonany do formatu MP4 z kodekiem H.264. 
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5. WYNIKI PRACY 

Wynikiem niniejszej pracy jest krótka animacja oraz pięć wizualizacji, które ukazują kampus Krakowskiej 

Akademii. Dodatkowo wykonany został kompletny model 3D, który może zostać wykorzystany do innych 

celów. Poniżej znajduje się prezentacja uzyskanych rezultatów.  
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6. ZAKOŃCZENIE 

 

Grafika 3D, wizualizacje i animacje w przypadku projektów architektonicznych pełnią obecnie kluczową rolę. 

Stosunkowo niskie koszty wytworzenia, szybki czas realizacji i znaczne polepszenie komunikacji z klientami 

oraz inwestorami to tylko niektóre z niewątpliwych zalet tego typu realizacji.  

Podczas pisania pracy skupiłem się na możliwie najwierniejszym wymodelowaniu kampusu Krakowskiej 

Akademii. Wykorzystałem do tego celu wiedzę i doświadczenie zdobyte w pracy zawodowej. Zadanie nie było 

jednak łatwe, ponieważ nie miałem zbyt wiele dobrej jakości materiałów źródłowych, takich jak projekty lub 

rysunki elewacji. Mimo tego udało się uzyskać obiekt o wyglądzie zbliżonym do rzeczywistego, wykorzystując 

jedynie mapy internetowe i zdjęcia zrobione osobiście. Model, oprócz trzech budynków, zawiera również 

uproszczony teren Krakowskiej Akademii, rośliny i elementy małej architektury, takie jak ławki, donice, latarnie 

itp. Dla zachowania jak największej zgodności większość tekstur została wykonana w programie Adobe 

Photoshop przy użyciu wykonanych fotografii. Ze względu na ograniczenia dostępności sprzętu rendery 

postanowiłem wykonać w konwencji makiety architektonicznej, co ograniczyło konieczność modelowania 

dalszego otoczenia uczelni.  Wykorzystany silnik renderujący Vray pozwolił na szybkie i bezproblemowe 

oświetlenie sceny przy pomocy VrayPhysicalSun. Prosta animacja, wykonana przy użyciu narzędzia 

CameraMorph pozwala ukazać zakres wykonanej pracy w szerszej perspektywie. 

 Z pewnością dużą rolę odegrało tutaj wybrane do realizacji tego celu oprogramowanie. Cinema 4D znakomicie 

poradziła sobie z przedstawionym zadaniem, będąc jednocześnie efektywna, jak i bardzo wydajna. Ogrom 

dostępnych narzędzi, niezwykle ergonomiczny interfejs i szybkość działania znacząco ułatwiły wykonanie 

zadania. Również silnik renderujący Vray bardzo dobrze sprawdził się w projekcie dostarczając akceptowalne 

czasy renderu, co w przypadku animacji ma fundamentalne znaczenie. 

Zakres wykonanej pracy częściowo przedstawiają statystyki projektu: 

 Wielkość pliku: 216 937 KB 

 Punkty (vertex): 3 051 906 

 Wieloboki (polygons): 2 520 515 

 Obiekty: 2 919 

 Ilość wersji zapisu: 237 

Oczywiście wykonane wizualizacje mogłyby być znacznie bardziej realistyczne. Niestety w przypadku pracy 

niekomercyjnej jest to bardzo trudne do uzyskania ze względu na ograniczone zasoby sprzętowe i programowe. 

Mam tutaj również na myśli gotowe, płatne modele 3D np. roślinności, które zazwyczaj wykorzystuje się w 

pracy komercyjnej.  

Model 3D również mógłby zostać rozbudowany, np. o wnętrze budynków uczelni. Przy zachowaniu rozsądnej 

gospodarki złożonością poligonową modelu, można by na jego podstawie stworzyć aplikację lub grę 3D. Takie 

możliwości udostępnia np. silnik Unity, do którego bez trudu można wyeksportować pliki utworzone w 

programie Cinema 4D. Tego typu aplikacja mogłaby również zostać wykonana w technologii VR (Virtual 

Reality). Taka realizacja może być wykorzystana przez Krakowską Akademię w celach promocyjnych lub 

informacyjnych. Istnieje również możliwość wykonania wydruku modelu w technologii druku 3D.  

Przedstawione  metody i techniki pracy nad projektem 3D mogą znaleźć zastosowanie przy tworzeniu różnego 

rodzaju wizualizacji oraz modeli 3D, nie tylko architektonicznych. Znajdą również swoje zastosowanie dla 

użytkowników konkurencyjnych wobec pakietu firmy Maxon programów takich jak 3D Studio Max, Maya, 

Blender itp.  

Moim zdaniem Cinema 4D to jeden z najlepszych wyborów jeśli chodzi o grafikę 3D. Szybkość i stabilność 

działania, wsparcie producenta, duża społeczność użytkowników, wszechstronność i najlepszy interfejs 

użytkownika sprawiają, że warto zwrócić uwagę na ten pakiet. 
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9. WYKAZ GOTOWYCH MODELI 3D WYKORZYSTANYCH W PROJEKCIE 

Podczas tworzenia projektu wykorzystane zostały gotowe modele 3D rośli oraz samochodów. Wykaz 

zastosowanych elementów znajduje się poniżej.  

Audi RS4: 
https://www.cgtrader.com/free-3d-models/car/standard/audi-rs4-avant-b8-typ-8k-2013 

BMW X5: 
https://www.cgtrader.com/free-3d-models/car/suv/bmw-x5-4-8is-e53 

Toyota Prius: 

https://www.cgtrader.com/free-3d-models/car/standard/toyota-prius-xw30-2010-
6bf1f6129edb9fbe2223b12e59cabb36 

Subaru BRZ: 

https://www.cgtrader.com/free-3d-models/car/sport/subaru-brz-fa20-2014-
f67dfe4c9ca398afa382ba95e12022a2 

Volkswagen Polo: 

https://www.cgtrader.com/free-3d-models/car/standard/volkswagen-polo-gti-mk5-typ-
6r-2012-8392cce279a5dc585cdc185de11724cf 

Mazda 6: 
https://www.cgtrader.com/free-3d-models/car/standard/mazda-mazda6-sport-2008-
35d194e8c19474d9627bb41c8cae904e 

Honda Accord: 

https://www.cgtrader.com/free-3d-models/car/standard/honda-accord-3-5-sv-2011 

Renault Megane: 

https://www.cgtrader.com/free-3d-models/car/sport/renault-megane-3-rs-
8580c8ca6875ab2fa328a5e1e08ff03a 

Smart Fortwo: 

https://www.cgtrader.com/free-3d-models/car/standard/smart-fortwo--2 

Birch Tree: 

https://www.viz-people.com/portfolio/free-3d-models-trees/ 

Italian Maple Tree, European Ash, Lombardy Poplar Tree, Cherry Tree, Willow, Ahorn, Sweet Birch, fir, 

bush, thuja, Medlar Tree, Elderberry Tree, Crack Willow, Black Poplar, Common Juniper: 

Cinema 4D Content Browser Visualize 


